uncategorized

Running FreeNAS 9.2.1.8 USB Image in Chroot on ZFS Root

I don’t use this anymore, but kept the instructions here for future reference

Create mfsbsd-mkzfsroot.sh with these contents:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
#!/bin/sh
# $Id$
#
# this is mmatuska's zfsinstall without EXTRACT, URL, ARCHIVE and zpool.cache
#
# mfsBSD ZFS install script
# Copyright (c) 2011-2013 Martin Matuska <mm at FreeBSD.org>
#
FS_LIST="var tmp"

usage() {
echo "Usage: $0 [-h] -d geom_provider [-d geom_provider ...] [-r mirror|raidz] [-m mount_point] [-p zfs_pool_name] [-V zfs_pool_version] [-s swap_partition_size] [-z zfs_partition_size] [-c] [-l] [-4]"
}

help() {
echo; echo "Install FreeBSD using ZFS from a compressed archive"
echo; echo "Required flags:"
echo "-d geom_provider : geom provider(s) to install to (e.g. da0)"
echo; echo "Optional flags:"
echo "-r raidz|mirror : select raid mode if more than one -d provider given"
echo "-s swap_part_size : create a swap partition with given size (default: no swap)"
echo "-z zfs_part_size : create zfs parition of this size (default: all space left)"
echo "-p pool_name : specify a name for the ZFS pool (default: tank)"
echo "-V pool_version : specify a version number for ZFS pool (default: 13)"
echo "-m mount_point : use this mount point for operations (default: /mnt)"
echo "-c : enable lzjb compression for all datasets"
echo "-l : use legacy mounts (via fstab) instead of ZFS mounts"
echo "-4 : use fletcher4 as default checksum algorithm"
echo; echo "Examples:"
echo "Install on a single drive with 2GB swap:"
echo "$0 -u /path/to/release -d da0 -s 2G"
echo "Install on a mirror without swap, pool name rpool:"
echo "$0 -u /path/to/release -d da0 -d da1 -r mirror -p rpool"
echo; echo "Notes:"
echo "When using swap and raidz/mirror, the swap partition is created on all drives."
echo "The /etc/fstab entry will contatin only the first drive's swap partition."
echo "You can enable all swap partitions and/or make a gmirror-ed swap later."
}

while getopts d:u:t:r:p:s:z:m:V:hcl4 o; do
case "$o" in
d) DEVS="$DEVS ${OPTARG##/dev/}" ;;
p) POOL="${OPTARG}" ;;
s) SWAP="${OPTARG}" ;;
m) MNT="${OPTARG}" ;;
r) RAID="${OPTARG}" ;;
z) ZPART="${OPTARG}" ;;
V) VERSION="${OPTARG}" ;;
c) LZJB=1 ;;
l) LEGACY=1 ;;
4) FLETCHER=1 ;;
h) help; exit 1;;
[?]) usage; exit 1;;
esac
done

if ! `/sbin/kldstat -m zfs >/dev/null 2>/dev/null`; then
/sbin/kldload zfs >/dev/null 2>/dev/null
fi

ZFS_VERSION=`/sbin/sysctl -n vfs.zfs.version.spa 2>/dev/null`

if [ -z "$ZFS_VERSION" ]; then
echo "Error: failed to load ZFS module"
exit 1
elif [ "$ZFS_VERSION" -lt "13" ]; then
echo "Error: ZFS module too old, version 13 or higher required"
exit 1
fi

if [ -z "$DEVS" ]; then
usage
exit 1
fi

if [ -z "$POOL" ]; then
POOL=tank
fi

if [ -z "$VERSION" ]; then
VERSION=${ZFS_VERSION}
elif [ "$VERSION" -gt "$ZFS_VERSION" ]; then
echo "Error: invalid ZFS pool version (maximum: $ZFS_VERSION)"
exit 1
fi

if [ "$VERSION" = "5000" ]; then
VERSION=
else
VERSION="-o version=${VERSION}"
fi

if /sbin/zpool list $POOL > /dev/null 2> /dev/null; then
echo Error: ZFS pool \"$POOL\" already exists
echo Please choose another pool name or rename/destroy the existing pool.
exit 1
fi

EXPOOLS=`/sbin/zpool import | /usr/bin/grep pool: | /usr/bin/awk '{ print $2 }'`

if [ -n "${EXPOOLS}" ]; then
for P in ${EXPOOLS}; do
if [ "$P" = "$POOL" ]; then
echo Error: An exported ZFS pool \"$POOL\" already exists
echo Please choose another pool name or rename/destroy the exported pool.
exit 1
fi
done
fi

COUNT=`echo ${DEVS} | /usr/bin/wc -w | /usr/bin/awk '{ print $1 }'`
if [ "$COUNT" -lt "3" -a "$RAID" = "raidz" ]; then
echo "Error: raidz needs at least three devices (-d switch)"
exit 1
elif [ "$COUNT" = "1" -a "$RAID" = "mirror" ]; then
echo "Error: mirror needs at least two devices (-d switch)"
exit 1
elif [ "$COUNT" = "2" -a "$RAID" != "mirror" ]; then
echo "Notice: two drives selected, automatically choosing mirror mode"
RAID="mirror"
elif [ "$COUNT" -gt "2" -a "$RAID" != "mirror" -a "$RAID" != "raidz" ]; then
echo "Error: please choose raid mode with the -r switch (mirror or raidz)"
exit 1
fi

for DEV in ${DEVS}; do
if ! [ -c "/dev/${DEV}" ]; then
echo "Error: /dev/${DEV} is not a block device"
exit 1
fi
if /sbin/gpart show $DEV > /dev/null 2> /dev/null; then
echo "Error: /dev/${DEV} already contains a partition table."
echo ""
/sbin/gpart show $DEV
echo "You may erase the partition table manually with the destroygeom command"
exit 1
fi
done

if [ -z "$MNT" ]; then
MNT=/mnt
fi

if ! [ -d "${MNT}" ]; then
echo "Error: $MNT is not a directory"
exit 1
fi

if [ -n "${ZPART}" ]; then
SZPART="-s ${ZPART}"
fi

if [ "${LEGACY}" = "1" ]; then
ALTROOT=
ROOTMNT=legacy
else
ALTROOT="-o altroot=${MNT}"
ROOTMNT=/
fi

# Create GPT

for DEV in ${DEVS}; do
echo -n "Creating GUID partitions on ${DEV} ..."
if ! /sbin/gpart create -s GPT /dev/${DEV} > /dev/null; then
echo " error"
exit 1
fi
/bin/sleep 1
if ! echo "a 1" | /sbin/fdisk -f - ${DEV} > /dev/null 2> /dev/null; then
echo " error"
exit 1
fi
if ! /sbin/gpart add -t freebsd-boot -s 128 ${DEV} > /dev/null; then
echo " error"
exit 1
fi
if [ -n "${SWAP}" ]; then
if ! /sbin/gpart add -t freebsd-swap -s "${SWAP}" ${DEV} > /dev/null; then
echo " error"
exit 1
fi
SWAPPART=`/sbin/glabel status ${DEV}p2 | /usr/bin/grep gptid | /usr/bin/awk '{ print $1 }'`
if [ -z "$SWAPPART" ]; then
echo " error determining swap partition"
fi
if [ -z "$FSWAP" ]; then
FSWAP=${SWAPPART}
fi
fi
if ! /sbin/gpart add -t freebsd-zfs ${SZPART} ${DEV} > /dev/null; then
echo " error"
exit 1
fi
/bin/dd if=/dev/zero of=/dev/${DEV}p2 bs=512 count=560 > /dev/null 2> /dev/null
if [ -n "${SWAP}" ]; then
/bin/dd if=/dev/zero of=/dev/${DEV}p3 bs=512 count=560 > /dev/null 2> /dev/null
fi
echo " done"

echo -n "Configuring ZFS bootcode on ${DEV} ..."
if ! /sbin/gpart bootcode -b /boot/pmbr -p /boot/gptzfsboot -i 1 ${DEV} > /dev/null; then
echo " error"
exit 1
fi
echo " done"
/sbin/gpart show ${DEV}
done

# Create zpool and zfs

for DEV in ${DEVS}; do
PART=`/sbin/gpart show ${DEV} | /usr/bin/grep freebsd-zfs | /usr/bin/awk '{ print $3 }'`

if [ -z "${PART}" ]; then
echo Error: freebsd-zfs partition not found on /dev/$DEV
exit 1
fi

GPART=`/sbin/glabel list ${DEV}p${PART} | /usr/bin/grep gptid | /usr/bin/awk -F"gptid/" '{ print "gptid/" $2 }'`

GPARTS="${GPARTS} ${GPART}"
PARTS="${PARTS} ${DEV}p${PART}"
done

echo -n "Creating ZFS pool ${POOL} on${PARTS} ..."
if ! /sbin/zpool create -f -m none ${ALTROOT} ${VERSION} ${POOL} ${RAID} ${PARTS} > /dev/null 2> /dev/null; then
echo " error"
exit 1
fi
echo " done"

if [ "${FLETCHER}" = "1" ]; then
echo -n "Setting default checksum to fletcher4 for ${POOL} ..."
if ! /sbin/zfs set checksum=fletcher4 ${POOL} > /dev/null 2> /dev/null; then
echo " error"
exit 1
fi
echo " done"
fi

if [ "${LZJB}" = "1" ]; then
echo -n "Setting default compression to lzjb for ${POOL} ..."
if ! /sbin/zfs set compression=lzjb ${POOL} > /dev/null 2> /dev/null; then
echo " error"
exit 1
fi
echo " done"
fi

echo -n "Creating ${POOL} root partition:"
if ! /sbin/zfs create -o mountpoint=${ROOTMNT} ${POOL}/root > /dev/null 2> /dev/null; then
echo " error"
exit 1
fi
echo " ... done"
echo -n "Creating ${POOL} partitions:"
for FS in ${FS_LIST}; do
if [ "${LEGACY}" = 1 ]; then
MNTPT="-o mountpoint=legacy"
else
MNTPT=
fi
if ! /sbin/zfs create ${MNTPT} ${POOL}/root/${FS} > /dev/null 2> /dev/null; then
echo " error"
exit 1
fi
echo -n " ${FS}"
done
echo " ... done"
echo -n "Setting bootfs for ${POOL} to ${POOL}/root ..."
if ! /sbin/zpool set bootfs=${POOL}/root ${POOL} > /dev/null 2> /dev/null; then
echo " error"
exit 1
fi
echo " done"
/sbin/zfs list -r ${POOL}

# Mount and populate zfs (if legacy)
if [ "${LEGACY}" = "1" ]; then
echo -n "Mounting ${POOL} on ${MNT} ..."
/bin/mkdir -p ${MNT}
if ! /sbin/mount -t zfs ${POOL}/root ${MNT} > /dev/null 2> /dev/null; then
echo " error mounting pool/root"
exit 1
fi
for FS in ${FS_LIST}; do
/bin/mkdir -p ${MNT}/${FS}
if ! /sbin/mount -t zfs ${POOL}/root/${FS} ${MNT}/${FS} > /dev/null 2> /dev/null; then
echo " error mounting ${POOL}/root/${FS}"
exit 1
fi
done
echo " done"
fi

# Adjust configuration files

echo -n "Writing /boot/loader.conf..."
install -d -m 755 ${MNT}/boot
echo "zfs_load=\"YES\"" > ${MNT}/boot/loader.conf

echo "vfs.root.mountfrom=\"zfs:${POOL}/root\"" >> ${MNT}/boot/loader.conf
echo " done"

# Write fstab if swap or legacy
echo -n "Writing /etc/fstab..."
install -d -m 755 ${MNT}/etc
rm -f ${MNT}/etc/fstab
touch ${MNT}/etc/fstab
if [ -n "${FSWAP}" -o "${LEGACY}" = "1" ]; then
if [ -n "${FSWAP}" ]; then
echo "/dev/${FSWAP} none swap sw 0 0" > ${MNT}/etc/fstab
fi
if [ "${LEGACY}" = "1" ]; then
for FS in ${FS_LIST}; do
echo ${POOL}/root/${FS} /${FS} zfs rw 0 0 >> ${MNT}/etc/fstab
done
fi
fi
if [ "${LEGACY}" != "1" ]; then
echo -n "Writing /etc/rc.conf..."
echo 'zfs_enable="YES"' >> ${MNT}/etc/rc.conf
fi
echo " done"

if [ -n "${LEGACY}" ]; then
for FS in ${FS_LIST}; do
/sbin/umount ${MNT}/${FS} > /dev/null 2> /dev/null
done
/sbin/umount ${MNT} > /dev/null 2> /dev/null
fi
if ! /sbin/zpool export ${POOL} > /dev/null 2> /dev/null; then
echo " error exporting pool"
exit 1
fi
if ! /sbin/zpool import ${ALTROOT} ${POOL} > /dev/null 2> /dev/null; then
echo " error importing pool"
exit 1
fi
if [ -n "${LEGACY}" ]; then
if ! /sbin/mount -t zfs ${POOL}/root ${MNT} > /dev/null 2> /dev/null; then
echo " error mounting ${POOL}/root"
exit 1
fi
fi
if [ -n "${LEGACY}" ]; then
for FS in ${FS_LIST}; do
if ! /sbin/mount -t zfs ${POOL}/${FS} ${MNT}/${FS} > /dev/null 2> /dev/null; then
echo " error mounting ${POOL}/${FS}"
exit 1
fi
done
fi
echo " done"

echo "WARNING - Don't export ZFS pool \"${POOL}\"!"

I boot from my LiveISO-USB, then

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
echo "192.168.255.100 chill.home.local" >> /etc/hosts
DRIVE=ada0
ZFSCOPIES=2
IMAGE=FreeNAS-9.2.1.8-RELEASE-x64.img

# Destroy drive
#destroygeom -d ${DRIVE}
if gpart show ${DRIVE} > /dev/null 2> /dev/null ; then
echo "ERROR: ${DRIVE} is not empty. Wipe with: destroygeom -d ${DRIVE}" >&2
exit 1
fi

# Use modified zfsinstall script (mfsbsd-mkzfsroot.sh) from above
chmod a+x mfsbsd-mkzfsroot.sh
./mfsbsd-mkzfsroot.sh -d ${DRIVE} -p autoroot
zfs destroy autoroot/root/tmp
zfs destroy autoroot/root/var
rm -r /mnt/etc
zfs set copies=${ZFSCOPIES} autoroot

# Fetch FreeNAS USB running image
if [ ! -e /mnt/${IMAGE} ]; then
rsync -vitP [email protected]:~/Downloads/freebsd/freenas/${IMAGE} /mnt/
fi

# Mount LiveISO-USB
mkdir /liveusb
mkdir /cdrom
if [ ! -e /dev/da0s1 ]; then
echo "ERROR: LiveISO-USB device not found!" >&2
exit 1
fi
mount_msdosfs -o ro /dev/da0s1 /liveusb
if [ ! -e /liveusb/boot/iso/mfsbsd-se-10.0-RELEASE-amd64.iso ]; then
echo "ERROR: mfsBSD ISO not found!" >&2
exit 1
fi

# Mount mfsBSD ISO
mfsiso=$( mdconfig -a -t vnode -f /liveusb/boot/iso/mfsbsd-se-10.0-RELEASE-amd64.iso )
mount_cd9660 /dev/${mfsiso} /cdrom

# Copy /boot
tar -x -C /mnt --include boot -f /cdrom/10.0-RELEASE-amd64/kernel.txz
rm /mnt/boot/kernel/kernel
rm /mnt/boot/kernel/*symbols
rsync -viaP /boot/ /mnt/boot/
rsync -viaP --exclude 10.0-RELEASE-amd64 /cdrom/ /mnt/

# Modify /mnt/boot/loader.conf
cat >>/mnt/boot/loader.conf <<EOF
zfs_load="YES"
hw.bge.allow_asf="0"
hw.usb.no_shutdown_wait="1"
vfs.zfs.arc_max="256000000"
EOF
grep -v 'mfsbsd.autodhcp' /mnt/boot/loader.conf > bootloader.conf
cat bootloader.conf > /mnt/boot/loader.conf
mv /mnt/boot /mnt/boot2

# First mount of FreeNAS running image
freenas=$( mdconfig -a -t vnode -f /mnt/${IMAGE} )
mkdir /freenas
mount /dev/ufs/FreeNASs1a /freenas
rm /freenas/etc/rc.d/mountlate 2> /dev/null
rm /freenas/conf/base/etc/rc.d/mountlate 2> /dev/null

# Copy FreeNAS /freenas/boot to /mnt/boot
rsync -viaP /freenas/boot/ /mnt/boot/
rsync -viaP /freenas/usr/ /mnt/usr/

# Merge mfsBSD and FreeNAS /mnt/boot/loader.conf
cat /mnt/boot/loader.conf >> /mnt/boot2/loader.conf
cat /mnt/boot2/loader.conf > /mnt/boot/loader.conf
rm -r /mnt/boot2

# Modify /mnt/boot/loader.conf
grep -v 'module_path' /mnt/boot/loader.conf > bootloader.conf
cat bootloader.conf > /mnt/boot/loader.conf
cat >>/mnt/boot/loader.conf <<EOF
module_path="/boot/kernel;/boot/modules;/usr/local/modules;/mnt/boot/kernel;/mnt/boot/modules;/mnt/usr/local/modules"
EOF

# Mount mfsroot
cd /mnt
gunzip mfsroot.gz
mfsroot=$( mdconfig -a -t vnode -f /mnt/mfsroot )
mkdir /mfsroot
mount /dev/${mfsroot} /mfsroot

# Modify rc.local
mkdir /testroot
tar -x -C /testroot/ -f /mfsroot/root.txz
cat >>/testroot/rw/etc/rc.local <<EOF

# Import autoroot and start freenas chroot script
zpool status autoroot || zpool import -f -R /mnt autoroot
sh /mnt/freenas.sh
EOF
chmod a+x /testroot/rw/etc/rc.local
cd /testroot
tar -cf - ./ | xz - > /mfsroot/root.txz
umount /mfsroot
mdconfig -d -u ${mfsroot}

# freenas chroot script
cat >/mnt/freenas.sh <<EOF
#!/bin/sh
freenas=\$( mdconfig -a -t vnode -f /mnt/${IMAGE} )
mkdir /freenas
mount /dev/ufs/FreeNASs1a /freenas
mount /dev/ufs/FreeNASs3 /freenas/cfg
mount /dev/ufs/FreeNASs4 /freenas/data
mount -t devfs devfs /freenas/dev
# Link these for mfsbsd's roothack init
test -e /freenas/freenas || ln -s / /freenas/freenas
test -e /freenas/rw || ln -s / /freenas/rw
# Start FreeNAS rc
chroot /freenas sh /etc/rc
EOF

reboot

And unplug my LiveISO-USB!

Share